• May
  • 26
  • 2015

IT

Xitrum 3.24.0

Xitrum 3.24.0 Released!

https://groups.google.com/d/msg/xitrum-framework/RHv1cgXQAHI/23b78PuchiAJ

主な変更点

1. #535 Componentの言語が常に"en"となってしまうバグが修正されました。

2. #527 Nettyのバージョンが4.0.26から4.0.28になりました。

3. #528 Akkaのバージョンが2.3.8から2.3.11になりました。

今回のリリースからセマンティックバージョニングに準拠するようになりました。
例えば Xitrum 3.24.1はXitrum 3.24.0と互換性があります。
Xitrum 3.25.0はXitrum 3.24.xとは互換性がなくなります。


3.23.1 から 3.24.0 へのアップデート方法

build.sbtを修正します。(3.24.0は基本的には3.23と互換性があります。)
参考: https://github.com/xitrum-framework/xitrum-new/commit/6cc7bff09b19d2ecc91e4f82bfeaecf5ebf5ff9e

-libraryDependencies += "tv.cntt" %% "xitrum" % "3.23.1"
            +libraryDependencies += "tv.cntt" %% "xitrum" % "3.24.0"

Comments

*